1. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

DarkRP 2.6.0 has been released!

Discussion in 'DarkRP News and Announcements' started by (FPtje) Atheos, Feb 21, 2015.

  1. (FPtje) Atheos

    (FPtje) Atheos Main Developer Staff Member

    [​IMG]
    DarkRP has updated!

    Everyone rejoice! Version 2.6.0 has been released!

    The update will be installed automatically if you're on the workshop version of DarkRP.
    People using the GitHub version will have to update manually. Download the latest version here:
    https://github.com/FPtje/DarkRP

    Biggest changes:

    • Better error mechanism. It tells you what's wrong and what to do when an error occurs.
    • Jobs, shipments and all that stuff are more strictly checked. DarkRP will tell you when you've made mistakes.
    • Lots of bug fixes, speed improvements and all that stuff depending on when you last updated.
    ALL addons, the darkrpmod and your custom stuff will work on DarkRP 2.6.0. You don't have to worry about that.

    Unless of course you edited DarkRP core files. Only then will everything break.
    Obviously this happens because you are a terrible person.
     
  2. konamikode

    konamikode Member

    Awesome update!
    Thanks.
     
  3. CreepyTrollerr

    CreepyTrollerr New Member

    nice!
     
    konamikode likes this.
  4. McSniper

    McSniper New Member

    Thank you so much! I'm really excited for it :)

    Can't wait to test ALL my addons on it xD

    yay.......... :p
     
    konamikode likes this.
  5. NerdyNA

    NerdyNA New Member

    Hooray!
     
    konamikode likes this.
  6. Splash

    Splash New Member

    Thanks you ! I make a darkrp french server and i your gamemode it's very great! Thanks you for you free work, you are great script and great man :) !
     
    konamikode likes this.
  7. iTechGaming

    iTechGaming New Member



    Hello,

    I would like to have the link to download DarkRP 2.6 because the link you put redirects to the last version that is now 2.7 :(.

    Thanks.
     
  8. (FPtje) Atheos

    (FPtje) Atheos Main Developer Staff Member

    Not going to happen. Install the latest version.
     
  9. iTechGaming

    iTechGaming New Member

    No, I want the DarkRP 2.6 because I do not like 2.7, so please, you're suppose to help not annoy people. Thanks. I am still waiting.
     
  10. (FPtje) Atheos

    (FPtje) Atheos Main Developer Staff Member

    I don't give a shit about what you like. You don't get to decide that I'm supposed to help people. DarkRP 2.7.0 is the version of DarkRP you can download. Other versions of DarkRP are not available anymore.

    There isn't even any user facing difference between 2.6.2 and 2.7.0. There's nothing not to like about 2.7.0 that you would like in 2.6.2.

    Wait all you want. I'm not going to make the download available.
     
  11. iTechGaming

    iTechGaming New Member

    ''Main Developer''
    ''Staff Member''

    Those people should help. Alright, DarkRP 2.7 is fucking worse then DarkRP 2.5/2.6, PLUS there's so many addons that aren't able to run in DarkRP 2.6, THAT'S WHY... I need to download DarkRP 2.6.
    Now, you get it ?!
     
  12. (FPtje) Atheos

    (FPtje) Atheos Main Developer Staff Member

    No, I don't, because you fail to substantiate your claim. Name one difference between 2.7 and 2.6 that makes 2.7 worse.
     
  13. iTechGaming

    iTechGaming New Member

    there's so many addons that aren't able to run in DarkRP 2.6
     
  14. (FPtje) Atheos

    (FPtje) Atheos Main Developer Staff Member

    I'll assume you're talking about 2.7, since that's the version that you seemingly want. The question remains: because of what difference?

    You don't even know that. Fuck, I suspect you don't even want 2.6. You probably want the ancient 2.4.3, since that was the last time backwards compatibility was broken.
     
  15. Telz

    Telz New Member

    What version doesnt have the advert as billboards?
     
  16. Mason

    Mason New Member

    2.7 has fucking billboards as adverts, im sorry but I bet that like 3/10 darkrp server owners want that shit... I know I sure dont.
     
  17. why the advert thing D;
     
  18. [EG] Phoenix

    [EG] Phoenix Member

    Just curious. Will you ever make DarkRP have better stock printers and weapons? Like I know that's what darkrpmodification is for, but like change the original crappy css weapons with more better weapons?
     
  19. NV Sam Pepper

    NV Sam Pepper Member

    More Better Weapons.


    Kek
     
  20. Twitcher

    Twitcher New Member

    You should be able to do it yourself. He's not obligated to make "amazing" stock printers, and weapons. Use the workshop, or make your own.
     

Share This Page