1. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

Money Error & Joining/connecting Error

Discussion in 'Modder General Chat' started by [IG] Skeptic, Mar 3, 2016.

  1. [IG] Skeptic

    [IG] Skeptic New Member

    Hi, I have a problem with my DarkRP server. I have not touched any DarkRP gamemode core files and I have tried reinstalling the DarkRP gamemode numerous times. When the server first starts, everything is fine. If it stays up for 1-2 hours everyones money is randomly set to 0 and when new players join, their team is set to "Joining/Connecting" Until they choose a job from the F4 Menu. With the Joining/connecting error, I do have my settings set to a default job that players should spawn as, so this isn't the issue. As for the money, I have no idea. The only thing that fixes this is a server restart, but then the same thing just happens again after 1-2 hours of the server being up.

    If anyone has a solution to fix this issue, please let me know

    Thanks.

    EDIT: This is the only Error I could find relative to DarkRP

    Lua Error: [ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:239: attempt to index local 'jobTable' (a nil value) 1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:239

    Another error that happens: Lua Error: [ERROR] gamemodes/darkrp/gamemode/libraries/fn.lua:252: attempt to index local 'xs' (a nil value) 1. isMayor - gamemodes/darkrp/gamemode/libraries/fn.lua:252 2. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:807
     
  2. Sir Klutch

    Sir Klutch Active Member

    Sounds like a database issue, are you using MySQL?
     
  3. [IG] Skeptic

    [IG] Skeptic New Member

    No, DarkRP isn't using MySQL.
    --- Double Post Merged, Mar 3, 2016 ---
    Also a new error appeared:

    Lua Error: [ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:676: attempt to index local 'jobTable' (a nil value) 1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:676
     
    Last edited: Mar 3, 2016
  4. Dookin Foof Lord

    Dookin Foof Lord New Member

    Bump, Im geting this too
    Hear is my conceal

    -----------------------------------------------------------------------------------------

    Code (Text):
    VAC secure mode is activated.


    Dookin Foof Lord is joining the server
    Client "Dookin Foof Lord" connected (192.168.1.19:27006).
    Writing cfg/banned_user.cfg.
    Spawning textscreens...
    ServerLog: [FAdmin] Dookin Foof Lord (STEAM_0:1:82041224) is Authed

    [ERROR] addons/gtime/lua/ulx/xgui/server/sv_utime.lua:76: Error on Query: SELECT * FROM utime JOIN utime_playerinformation ON (utime.player = utime_playerinformation.uid)
      1. error - [C]:-1
       2. Query - addons/gtime/lua/ulx/xgui/server/sv_utime.lua:76
        3. getTable - addons/gtime/lua/ulx/xgui/server/sv_utime.lua:96
         4. saveClientData - addons/gtime/lua/ulx/xgui/server/sv_utime.lua:91
          5. fn - addons/gtime/lua/ulx/xgui/server/sv_utime.lua:16
           6. unknown - addons/ulib/lua/ulib/shared/hook.lua:110


    [ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:606: attempt to index local 'jobTable' (a nil value)
      1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:606

    ServerLog: [FAdmin] Dookin Foof Lord (STEAM_0:1:82041224) Spawned

    [ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:715: attempt to index local 'jobTable' (a nil value)
      1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:715

    [Dookin Foof Lord|2|STEAM_0:1:82041224] Lua Error:

    [ERROR] addons/darkrp_stungun_544166339/lua/autorun/darkrp_stungun_resources.lua:2: 'then' expected near ')'
      1. unknown - addons/darkrp_stungun_544166339/lua/autorun/darkrp_stungun_resources.lua:0


    [Dookin Foof Lord|2|STEAM_0:1:82041224] Lua Error:

    [DarkRP] A runtime error has occurred in "addons/darkrpmodification-master/lua/darkrp_customthings/categories.lua" on line 105.
    The best help I can give you is this:

    Corrupt category: Drugs!
    The categorises must be one of "jobs", "entities", "shipments", "weapons", "vehicles", "ammo"

    Hints:
            - Mind that this is case sensitive.
            - Also mind the quotation marks.

    The responsibility for the error above lies with (the authors of) one (or more) of these files:
            1. addons/darkrpmodification-master/lua/darkrp_customthings/categories.lua on line 105
            2. function 'doInclude'
            3. gamemodes/darkrp/gamemode/libraries/modificationloader.lua on line 137
            4. gamemodes/darkrp/gamemode/libraries/modificationloader.lua on line 148
            5. gamemodes/darkrp/gamemode/cl_init.lua on line 53
    ------- End of Simplerr error -------

      1. error - [C]:-1
       2. error - gamemodes/darkrp/gamemode/libraries/simplerr.lua:530
        3. createCategory - gamemodes/darkrp/gamemode/modules/base/sh_createitems.lua:821
         4. unknown - addons/darkrpm
    [ERROR] RunString:1: unexpected symbol near '<'
      1. unknown - RunString:0

    Unhandled Lua Refresh: [NAME:darkrp_customthings/categories.lua] [TYPE:!UNKNOWN]

    [ERROR] RunString:1: unexpected symbol near '<'
      1. unknown - RunString:0


    [ERROR] RunString:1: unexpected symbol near '<'
      1. unknown - RunString:0

    STEAMAUTH: Client Dookin Foof Lord received failure code 6
    STEAMAUTH: Client Dookin Foof Lord received failure code 6
    Dookin Foof Lord has left the server. (STEAM_0:1:82041224)

    [ERROR] gamemodes/darkrp/gamemode/libraries/fn.lua:252: attempt to index local 'xs' (a nil value)
      1. isMayor - gamemodes/darkrp/gamemode/libraries/fn.lua:252
       2. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:846

    Dropped Dookin Foof Lord from server (Client left game (Steam auth ticket has been canceled)
    )

    [ERROR] RunString:1: unexpected symbol near '<'
      1. unknown - RunString:0
     
  5. Pab14567

    Pab14567 Well-Known Member

    You have an error in your jobs,

    stungun is causing an error, either you're using a leak or contact the author.

    Gtime is causing a error with query. Fix it
     
  6. Dookin Foof Lord

    Dookin Foof Lord New Member

    stungun is ok that do nothing to the server it's just that i doesn't set the job when
    --- Double Post Merged, Feb 7, 2017 ---
    Hear's is my code for custom jobs
     

    Attached Files:

    Last edited: Feb 7, 2017
  7. Pab14567

    Pab14567 Well-Known Member

  8. Dookin Foof Lord

    Dookin Foof Lord New Member

    Thanks a ton i found the problem it was the stungin stuff
     

Share This Page