1. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

(Solved) Looking For A Widely used addon

Discussion in 'DarkRP Modding Questions & Help' started by Hikkler, Feb 24, 2014.

  1. Hikkler

    Hikkler Member

    Hello, if you've looked through any server, you'll notice that they have yellow advert chat, and it says advert at the beginning, and if you look through ooc, is says (OOC) at the beginning... I was looking for a chat module, compatible with darkrp modfication for that.
     
  2. Bo98

    Bo98 Moderator Staff Member Contributor

    It's like that by default? Or am I misunderstanding what you are saying?
     
  3. Hikkler

    Hikkler Member

    I can show you on my server... if you'd like...
     
  4. [GG]Tense!

    [GG]Tense! Member

    Yea, you use "/advert Message goes here!" and it should come up as yellow, this is considered InCharacter on most servers.

    Although I am on 2.4.3, I'll look into the advert coding.
     
  5. Harbu

    Harbu Member

    I think he is asking for a Chat Customization Script, Such as AtlasChat ETC and are curious if they work with DarkRP in-game chat functions
     
  6. Hikkler

    Hikkler Member

    Pretty much, my advert is not yellow, and it says the prefix, there is no telling if I'm using advert or ooc.
     
  7. Hikkler

    Hikkler Member

    Or regular chat.
     
  8. Aoredon

    Aoredon New Member

    I'm confused...

    /ooc HI
    means
    [OOC] Aoredon: HI

    /advert HI
    means
    [Advert] Aoredon: HI
    ^ some servers don't show the name.
     
  9. Hikkler

    Hikkler Member

    My server shows:
    /advert HI
    [Gun Dealer] Hikkler: HI
    /ooc HI
    [Gun Dealer] Hikkler: HI
     
  10. Aoredon

    Aoredon New Member

    Hmm that's odd. I assumed it came with DarkRP. I'll check with my mate who owns a server when he's next online for ya!
     
  11. Reaver

    Reaver Member

    Do you get any errors in console when typing with ooc or advert in chat? Also, chattags like scripts for chattags that come from coderhire, can fuck up ooc and adverts, to where it doesnt show them, even though they are transmitting through correctly, so, it shows your job, which I'm assuming you DO have chattags or some form of script/mod that changes that. Uninstall that, and you should be able to see OOC and ADVERT again beside your name when using said types of chatter.
     
  12. Hikkler

    Hikkler Member

    Noop, we dont have anym and there are no errors
     
  13. [GG]Tense!

    [GG]Tense! Member

    The only thing I can suggest is a chat/name-tag mod might be clashing.
     
  14. stapler2025

    stapler2025 Member

    That's exactly what it is.
     
  15. Hikkler

    Hikkler Member

    I'll try ticketing my server company, perhaps they can tell... I wonder if condebug can show it?
     
  16. stapler2025

    stapler2025 Member

    There's nothing your server company can do. It's the chat tags that you're running on your server.

    "My server shows:
    /advert HI
    [Gun Dealer] Hikkler: HI
    /ooc HI
    [Gun Dealer] Hikkler: HI"

    Those are chat tags. DarkRP doesn't show those by itself, so something is modifying your chat to insert the players job title before their name. If you find that, then add prefixText before whatever you have setup to show the players team.
     
  17. Hikkler

    Hikkler Member

    The only problem is, I can't find it.
     
  18. stapler2025

    stapler2025 Member

    What addons do you have installed?
     
  19. Hikkler

    Hikkler Member

    Solved: It was an issue with the ulx teams that the previous dev set up thanks y'all
     
  20. Hikkler: How did u solve it? I have the latest Ulx Custom Commands installed and i have just that same error. Prefix is overwriting the original chat like OOC, [Advert], Yell. Would be awesome if you could help me im struggling to find a solution, i did spend over 12 hours to find one yday without results.

    Greets,
    Cheese

    Edit: I also tryed to get my activation mail from Ulysses over 2 months, i did also mail them directly to their staff, twice. With two different email adresses from two different hosts, and no activation mail yet, wired right?
    I hope you can help me.
     

Share This Page