1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

A problem with certain entities

Discussion in 'DarkRP Modding Questions & Help' started by Da Ceo, Aug 21, 2018.

  1. Da Ceo

    Da Ceo New Member

    Hello,
    First of all, i'm not an expert so please be indulgent, thanks
    I want to add some turret from J.I defense solution (https://steamcommunity.com/sharedfiles/filedetails/?id=295680095) into my F4 menu, but when i buy the turret, it doesn't work. It make a sound when i try to use it, but nothing more. And so my question wil be : Does anyone knows how to make it work ? I know some server had in the past. Or, is there another way to add entities ?
    If that can help, here is the dirty "code" i used :

    DarkRP.createEntity("Plinker Sentry", {
    ent = "ent_jack_turret_plinker",
    model = "models/Combine_turrets/Floor_turret.mdl",
    price = 0,
    max = 1,
    cmd = "buyplinkersentry",
    allowed = {TEAM_FLIC, TEAM_SWAT}
    })
     
  2. Afireal

    Afireal New Member

    i think it's due of entity's code, not darkrp
     
  3. cj2tech

    cj2tech Member

    well without looking at the coding for the addon do you hl1 and hl2 mounted to the server?
     
  4. Dancore

    Dancore Member

    Any errors?
     

Share This Page