1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

DarkRP is not working

Discussion in 'DarkRP Modding Questions & Help' started by Metiaz aka Pinezka, Apr 20, 2019.

  1. Metiaz aka Pinezka

    Metiaz aka Pinezka New Member

    Hello!
    I have a problem with DarkRP, and I'd like need help with that problem.
    In general it's like that when you start a game (no matter if you're a single player or a multiplayer) on any map, my whole console becomes flooded with a message:

    Warning! A net message (DarkRP_InitializeVars) is already started! Discarding in favor of the new message! (DarkRP_InitializeVars)

    [DarkRP] gamemodes/darkrp/gamemode/modules/base/sv_entityvars.lua:86: bad argument #1 to 'pairs' (table expected, got nil)
    1. pairs - [C]:-1
    2. sendDarkRPVars - gamemodes/darkrp/gamemode/modules/base/sv_entityvars.lua:86
    3. unknown - gamemodes/darkrp/gamemode/modules/base/sv_entityvars.lua:102
    4. unknown - lua/includes/modules/concommand.lua:54

    I tried everything I could to get rid of it: reinstalling DarkRP, installing DarkRP from github, verifying the integrity of Garry's mod files, but nothing worked.
    It is also worth mentioning that when I enter a some DarkRP server, it all works as it should.
    I will also attach 2 screenshots so you can see what my console looks like.
    Thank you for all your help.
    --- Double Post Merged, Apr 22, 2019 ---
    Alright, I found solution myself. I just had to reinstall my DarkRP-modification file. Now everything works.
     

    Attached Files:

    Last edited: Apr 22, 2019

Share This Page