1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

Having a problem with console errors

Discussion in 'DarkRP Modding Questions & Help' started by ◈ Kàeda the Catbot ◈, Jun 26, 2019.

  1. I'm getting errors in my console that usually are preceded by errors that tell me exactly where I did something wrong, but I'm not getting those specific errors, only the sv_gamemode_functions one, so now I'm confused, and have no idea what to look up, so I'm just gonna post my scripts here to see if any of you know what's wrong

    jobs.lua
    categories.lua
    shipments.lua

    I'm utterly confused, because this was all working before I restarted my server
     
  2. FireWolf

    FireWolf Member

    What's the error? Like the first, full error that shows up in the server console.
     
  3. [ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:633: attempt to index local 'jobTable' (a nil value)
    1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:633

    ServerLog: [FAdmin] ◈ Kàeda the Catbot ◈ (STEAM_0:0:197007937) Spawned

    [ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:758: attempt to index local 'jobTable' (a nil value)
    1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:758

    This is all it gives me, it doesn't give me the usual error telling me the exact line where something went wrong
     
  4. FireWolf

    FireWolf Member

    The line where chief = true is indented when it shouldn't be. See if that fixes it.
     
  5. I'm guessing you tried the script checking thing, I did too, it doesn't affect anything, it even says so on that github page
    --- Double Post Merged, Jun 27, 2019 ---
    Yeah I just tried it, changes literally nothing
     
    Last edited: Jun 27, 2019
  6. FireWolf

    FireWolf Member

  7. I switched from the workshop addon to the github version less than an hour ago, and it didn't change anything
    --- Double Post Merged, Jun 27, 2019 ---
    I just removed every addon that could modify spawning, and again, it changed literally nothing
     
    Last edited: Jun 27, 2019
  8. (FPtje) Atheos

    (FPtje) Atheos Main Developer Staff Member

    I don't think the error you gave is the earliest error. Look for errors on server startup. They will probably be more helpful.
     
    FireWolf likes this.

Share This Page