1. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

Help! Job's Weapons set are not ingame! [SOLVED]

Discussion in 'DarkRP Modding Questions & Help' started by ✅ Cyber Freak™, Sep 25, 2017.

  1. ✅ Cyber Freak™

    ✅ Cyber Freak™ New Member

    Hello there

    I have opened my server yesterday and I had to shut it down quick because all jobs didn't have there set weapons at all. There all on the job.lua file but there not on there job ingame. I have looked for errors to find none at all. I have removed some jobs to see if that would fix it and weirdly enough when I got a lua error the weapons would come back but once I fixed the lua error there gone again. It isn't only weapons its everything in the weapons = {""}, part of the code.

    At this point I got no idea how to fix is or where to even start. Any ideas?
  2. {NG} Mr. Nightmare

    {NG} Mr. Nightmare New Member

    Can you paste your code? And if you edited the darkRP core files, revert any changes and get the darkRP modification addon
    (FPtje) Atheos likes this.
  3. ✅ Cyber Freak™

    ✅ Cyber Freak™ New Member

    Oh I fixed this, it was another addon doing it. thanks for the reply
  4. {NG} Mr. Nightmare

    {NG} Mr. Nightmare New Member

    You may want to change your title to solved and say what add-on it was too help out anyone else having the problem ;)
  5. ✅ Cyber Freak™

    ✅ Cyber Freak™ New Member

    It was the undercover agent script doing it because it didn't have the police jobs set in its config file.

Share This Page