1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

[solved privat] Server lagging after a few hours

Discussion in 'Player General Chat' started by FearBomber, Nov 9, 2019.

  1. FearBomber

    FearBomber New Member

    hey. as the title says, my (DarkRP) server is lagging after a few hours online time. also once a player is spawning. i tryed edit the config (tickrate 66, 33 and 11) but nothing helps. i also temp. removed some "useless" addons, still no effect. is there any fix for it? (a friend of mine has the same problem)


    (if this is not related to here delete this please)
     
  2. se7ensins

    se7ensins Member

    OK i think your doing home hosting which is a good start but it will lag as you have the server open and play gmod at the same time. You can have the server running on another computer and play on another computer, make sure you internet flow is good ( use a eternal cable )
     
  3. FearBomber

    FearBomber New Member

    no, i got a rootserver from OVH (he also)

    edit*
    here is the server.cfg, if needed. i just removed servername and such stuff
    logging on
    sv_region 255
    sv_lan 0
    sv_logbans 1
    sv_logecho 1
    sv_logfile 1
    sv_log_onefile 0
    sv_allowcslua 0
    sv_noclipspeed 8
    sv_noclipaccelerate 8
    sv_timeout 600
    timeout 600
    //Sandbox Settings
    sbox_allownpcs 0
    sbox_maxtextscreens 10
    sbox_godmode 0
    sbox_plpldamage 0
    sbox_playergod 0
    sbox_noclip 0
    sbox_maxprops 100
    sbox_maxragdolls 0
    sbox_maxnpcs 0
    sbox_maxballoons 0
    sbox_maxeffects 0
    sv_respawntime 300
    sbox_maxdynamite 0
    sbox_maxlamps 0
    sbox_maxthrusters 0
    sbox_maxwheels 0
    sbox_maxhoverballs 0
    sbox_maxvehicles 0
    sbox_maxbuttons 6
    sbox_maxsents 0
    sbox_maxemitters 0
    sbox_maxspawners 0
    sbox_maxturrets 0
    //Server Settings
    sv_allowdownload 0
    sv_allowupload 0
    sv_loadingurl ""
    sv_downloadurl ""
    //Execute ban files
    exec banned_ip.cfg
    exec banned_user.cfg

    sv_stats "0"
    sv_mincmdrate "33"
    decalfrequency "10"
    sv_maxupdaterate "60"
    sv_minupdaterate "13"
    fps_max "550"
    sv_mincmdrate "0"

    sv_client_cmdrate_difference 1
    sv_client_predict 1
    sv_client_min_interp_ratio -1
    sv_client_max_interp_ratio -1

    mat_queue_mode "-1"
    gmod_mcore_test "1"
    cl_threaded_bone_setup "1"
    r_hunkalloclightmaps "0"
    heapsize "131072"

    sv_crazyphysics_wheels "1"
    sv_crazyphysics_warning "1"
    sv_crazyphysics_defuse "1"

    cl_lagcompensation 1
    cl_phys_props_max 20
    mp_decals 100


    sv_tickrate 11
    sv_maxupdate 33
    sv_maxcmdrate 33
    sv_minrate 1500
    sv_maxrate 30000

    heartbeat
     
    Last edited: Nov 11, 2019
  4. se7ensins

    se7ensins Member

    I mean i see you change it and it still doesn't work, idk what could be the problem its probably an addon or map size
     
  5. FearBomber

    FearBomber New Member

    playing on evocity maps (since they are good for 64 player). any other configs or settings i could add? or change anything?
     
  6. se7ensins

    se7ensins Member

    I mean theres some addons that do help, You can use them like APAnti which some prop from causing lag or some anitcheat that also protects from exploits. Or you can blacklist props that could cause this like big props.
    --- Double Post Merged, Nov 12, 2019 at 12:41 AM ---
    For me i used addon that protect it from laggin the server, i use:
    https://www.gmodstore.com/market/view/simplac-serverside-anticheat-with-low-resource-usage
    If you need help with this addon message me private i can help.
    --- Double Post Merged, Nov 12, 2019 at 12:44 AM ---
    Also use APAnti
     
    Last edited: Nov 12, 2019 at 12:44 AM
  7. FearBomber

    FearBomber New Member

    APAnti i used once, had not that effect. currently im running no anticheat since CAC got no updates anymore
     
  8. se7ensins

    se7ensins Member

    I got a really good anticheat that mostly blocks all exploits menu (private) CAC is trash its been cracked. Also you should probably use that link for that addon if you want.
    --- Double Post Merged, Nov 12, 2019 at 12:51 AM ---
    If you feel like non of that is going to help you. Change where you host it then or host off your own internet if its any good.
     
  9. FearBomber

    FearBomber New Member

    will check it out soon (buy it soon). i added new APAnti and will test it for now (in ~ 12 hours the server should lag or lag less / dont lag anymore, i will see)


    *edit*
    @se7ensins after a few hours its still lagging (mostly visible when u drive (TDM) cars, also once a player connects / spawns)
     
    Last edited: Nov 12, 2019 at 4:38 PM
  10. se7ensins

    se7ensins Member

    Can you pass me your server ip, I wanna see if the server lagging a lot when people join.
    --- Double Post Merged, Nov 13, 2019 at 7:17 PM ---
    Check server console if you get any errors when people connect. I used to have big lag problem when people used bitminers and the people joining crashed after. It could be a addons causing it, just double check the console for errors when people join.
    --- Double Post Merged, Nov 13, 2019 at 7:23 PM ---
    Also check server side addons errors.
     
    Last edited: Nov 13, 2019 at 7:23 PM
  11. FearBomber

    FearBomber New Member

    dropped u a privat message
     

Share This Page