1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Sign up for news, events and more!

    You're currently visiting the official DarkRP Forums as a guest. Sign up now to participate in our community and we'll let you know when we have news.

Unable to spawn cars + DarkRP gamemode crashed?

Discussion in 'Modder General Chat' started by Jonas13362, Jan 10, 2015.

  1. Jonas13362

    Jonas13362 New Member

    Hello ,



    If i try to spawn a car it tells me to look to darkrp config and enable the vehiclespawning but its locked to 2 (admin or higher) on darkrpmodification


    Greetings ,
    Jonas
     
    Last edited: Jan 14, 2015
  2. Jonas13362

    Jonas13362 New Member

    Running on 2.5.1 and i released i cant spawn NPC''s too after the update
     
  3. [XRAY]Blake

    [XRAY]Blake Active Member

    Do you have a vehicle limit?
     
  4. Jonas13362

    Jonas13362 New Member

    4 max and there arent any cars spawned
     
  5. Nick78111

    Nick78111 Member

    are you using ulx or fadmin or both?
     
  6. Jonas13362

    Jonas13362 New Member

  7. [XRAY]Blake

    [XRAY]Blake Active Member

    Are you actually set to superadmin?
     
  8. Jonas13362

    Jonas13362 New Member

    Jep im superadmin checked my rank at tab too and it says superadmin , even tried to login as rcon and spawn one but it still said that its disabled
     
  9. Jonas13362

    Jonas13362 New Member

    bumb any help please?
     
  10. Jonas13362

    Jonas13362 New Member

    None got any idea's ?
     
  11. Jonas13362

    Jonas13362 New Member

    Lately my darkrp crashed errorss of them ;
    Code (Text):

    [ERROR] gamemodes/darkrp/gamemode/modules/events.lua:79: attempt to call global 'AddChatCommand' (a nil value)
    1. unknown - gamemodes/darkrp/gamemode/modules/events.lua:79
    2. include - [C]:-1
    3. unknown - gamemodes/darkrp/gamemode/init.lua:43


    [ERROR] gamemodes/darkrp/gamemode/modules/voterestrictions/sv_init.lua:11: table index is nil
    1. unknown - gamemodes/darkrp/gamemode/modules/voterestrictions/sv_init.lua:11
    2. include - [C]:-1
    3. unknown - gamemodes/darkrp/gamemode/init.lua:58
     
    code from voterestrictions/sv_init:lua
    /*---------------------------------------------------------------------------
    Vote regulations
    - hobo's can't vote for anything (no voting rights for hobo's!)
    - Government jobs can't vote for gangster related things
    - Criminal jobs can't vote for government related things
    - Civilians can vote for anything

    Assumes the jobs are unedited in shared.lua, add them in the tables below to add your own jobs
    ---------------------------------------------------------------------------*/

    local GovernmentJobs = {
    [TEAM_MAYOR] = true,
    [TEAM_POLICE] = true,
    [TEAM_CHIEF] = true
    }

    local GangsterJobs = {
    [TEAM_GANG] = true,
    [TEAM_MOB] = true
    }

    local function decide(ply, target)
    if ply:Team() == TEAM_HOBO then return false, "Hobo's have no voting rights" end

    if GangsterJobs[ply:Team()] and GovernmentJobs[target:Team()] then
    return false, "Gangsters can't vote for government things!"
    end

    if GovernmentJobs[ply:Team()] and GangsterJobs[target:Team()] then
    return false, "Government officials can't vote for gangster things!"
    end
    end
    hook.Add("CanDemote", "VoteRegulations", decide)

    local function canVote(ply, vote)
    if vote.votetype ~= "job" and vote.votetype ~= "demote" then return end -- only apply to promotions and demotions
    if not IsValid(vote.target) then return end

    return decide(ply, vote.target)
    end
    hook.Add("CanVote", "VoteRegulations", canVote)
    events.lua :
    http://pastebin.com/bgcgmKXe
     
  12. Bo98

    Bo98 Moderator Staff Member Contributor

    Looks like some of your files are 2.4.3 versions. I recommend reinstalling DarkRP. Since all your changes are in the DarkRPModification addon then you won't lose anything.
     
  13. Jonas13362

    Jonas13362 New Member

    Jep somehow github version wasnt updated for me yesterday , now today i looked and it got updated 2 days ago
    Didnt see if car spawn works now but log is proper now , will get on topic again if car spawn doesnt work
    Thank you
     
  14. Jonas13362

    Jonas13362 New Member

    still having problem of it with spawning vehicles
     
  15. [XRAY]Blake

    [XRAY]Blake Active Member

    Did you go into the config.lua, change the admin spawn options, and SAVE it?
     
  16. Jonas13362

    Jonas13362 New Member

    Jep as i said its locked to nmber "2" , admin or higher if u mean that
     
  17. [XRAY]Blake

    [XRAY]Blake Active Member

    I think you might have or be editing the core files. Here is why.
    This is the code for admin spawn options in the core files config.lua
    Code (Text):

    -- adminvehicles - Whether or not vehicles should be admin only. 0 = everyone, 1 = admin or higher, 2 = superadmin or higher, 3 = rcon only
    GM.Config.adminvehicles                 = 3
     
    The 2 option is for superadmin or higher. Yet you said it's locked to number 2 for admin or higher. Not sure if this was an accident on your part... If so, make sure you doubke check your stuff.

    Here is the code for the settings.lua that you say is set to.
    Code (Text):

    -- adminvehicles - Whether or not vehicles should be admin only. 0 = everyone, 1 = admin or higher, 2 = superadmin or higher, 3 = rcon only
    GM.Config.adminvehicles                 = 2
     
    Same thing, yes. But make sure you didn't edit the core files.

    Maybe change it to 0 and see if you can spawn them in.

    One other thing I can think is you actually may not be superadmin. On the settings.lua Add your steam ID to the default admin thing.
    Secondly, go into rcon, type in "FAdmin SetRoot <yourname>"
     
  18. Jonas13362

    Jonas13362 New Member

    Its orginal darkrp...
    tried FAdmin SetRoot jonas13362 , it made me superadmin again as i was before but didnt do anything oging to try to change it to 0 but it isnt working if i do 1 or 2 ye i meant 1 for admin or higher let me give the config
    ofc its in darkrp modification


    http://pastebin.com/sxBnqqA3
     
  19. [XRAY]Blake

    [XRAY]Blake Active Member

    I don't really understand that. Can you please type more clearly and make sure you have full words, a noun, verb, subject, predicate, etc.
     
  20. Jonas13362

    Jonas13362 New Member

    As i tried to say in my text that im already root via fadmin and im also superadmin.
    im running a clean version of darkrp up to date. , i sended u the config of my darkrpmodification folder to show u it better.
    cant explain this better

    (excuse me)
     

Share This Page